Eliminating Noise coming from Lights

Knowledge Base for Thea for SketchUp
Locked
User avatar
george
Thea Render Team
Thea Render Team
Posts: 891
Joined: Wed Dec 02, 2015 10:25 am
Has thanked: 115 times
Been thanked: 22 times

The number one reason for having noise in a scene, is when a light's "volume" intersects with another geometry. Thea Lights have a parameter called 'Soft shadow - Radius (m)'. It equals to 0.02m and is enabled by default.

When enabled, an invisible sphere is being created with the defined value which is in meters. It is very important to have this number in mind when creating Lights because if the radius is too high, the "sphere" may intersect with any nearby geometry.

As a precaution, the first time a Thea Light is being created, it is being moved away from the point of creation by 1 inch.

In the following image you can see the setup of this simple scene.
Image 1: Scene Setup
Image 1: Scene Setup
In Image 2, the Spot Light has a Soft Radius value of 0.02m and is placed an inch away from a light with a passive emitter. This gives us a clean image.

The noise becomes visible as the Radius of the light increases. (Images 3 & 4)

Image 2: Soft shadow Radius - 0.02m
Image 2: Soft shadow Radius - 0.02m
Image 3: Soft shadow Radius - 0.5m
Image 3: Soft shadow Radius - 0.5m
Image 4: Soft shadow Radius enabled - 1.0m
Image 4: Soft shadow Radius enabled - 1.0m
Locked

Return to “Thea for SketchUp”