Texture

Get feedback on your current artwork.
Post Reply
antares333
Licensed User v1.5
Licensed User v1.5
Posts: 43
Joined: Wed Dec 03, 2014 4:51 pm
Has thanked: 1 time
Been thanked: 22 times

Tue May 07, 2019 7:49 am

Hello everyone,
I'm asking myself a question and i can't find any answser
I'm working on my road texture, and i'd like to have the possibility to add a white line on it but not everytime.
So i'm making my base road texture, but if i add the white line texture (like a decals) my whole texture become white (even if my decals is in PNG)
It's difficult to explain so i add you some screenshots.
Is there a way to blend them so i can play with my decals (make a larger if necessary without touching the base material)?
Thank you very much guys
Image
Attachments
1.JPG
2.JPG
User avatar
JQL
Thea Beta Tester
Thea Beta Tester
Posts: 5032
Joined: Sun Jun 23, 2013 6:34 pm
Location: Lisboa
Has thanked: 14 times
Been thanked: 92 times
Contact:

Tue May 07, 2019 9:31 am

A png has a RGB (red, green, blue) value attached to it as well as an Alpha, hence the RGBa.

That alpha is what makes it transparent.

Thea uses the RGB of the image on the diffuse slot, without alpha, that's why it's white.

For you to use the alpha of the image in this case you should insert the image on the layer weight slot, edit texture properties and select alpha channel instead of RGB.

This will be the right choice for this case material wise.

However what you could also do is use two faces, one with asphalt material and the other with the stripe.

That will allow you to model the stripes independently from the asphalt.
www.casca.pt
Visit us on facebook!

Win 10 64bit
Sketchup 2017 64bit
Intel i7 5820K 3.3Ghz 32Gb Ram
Nvidia Titan X 12Gb
User avatar
Rombout
Licensed User v1.5
Licensed User v1.5
Posts: 15254
Joined: Tue May 12, 2009 12:42 am
Location: Curacao, Netherland Antilles
Has thanked: 31 times
Been thanked: 271 times

Fri May 10, 2019 2:02 am

You use your stripe as a color map, you should use layer weight to mask that layer. Also make sure the stripe is white, now its th otherway around.

Nice seeing you use my Theme :)
Post Reply