Thea Render Revision 451/452/453

Development versions, documentation, tutorials and application resources may be found here.

Moderator: patricks

User avatar
giannis
Thea Developer
Thea Developer
Posts: 7986
Joined: Sun Jul 06, 2008 8:25 pm
Location: Athens, Greece

Note: updated to revision 452 with needed fix for opening IES file and various fixes related to photon mapping (improving consistency and removing black "dots" with BSD engine).
Science may limit knowledge but should never limit imagination - Bertrand Russell
19marco23
Licensed User v1.5
Licensed User v1.5
Posts: 413
Joined: Thu Apr 08, 2010 8:37 am

Thanks also from me, I'm looking forward to trying the new version.
User avatar
massimo
Licensed User v1.5
Licensed User v1.5
Posts: 1392
Joined: Wed May 13, 2009 7:24 pm
Location: Italy

Giannis, the problem still remains if you insert an IES light and try to browse a file in the content-->properties-->radiance panel. Also in the material editor you can browse an IES file but it only works if you apply first an emitter material from Materials-->emitters library, but not if you simply try to change, for example, an already applied color on a mesh to an emitter and then browse an IES file: the file appears loaded but no light is showed. :)
User avatar
giannis
Thea Developer
Thea Developer
Posts: 7986
Joined: Sun Jul 06, 2008 8:25 pm
Location: Athens, Greece

massimo wrote:Giannis, the problem still remains if you insert an IES light and try to browse a file in the content-->properties-->radiance panel.
Right! :oops:
massimo wrote:Also in the material editor you can browse an IES file but it only works if you apply first an emitter material from Materials-->emitters library, but not if you simply try to change, for example, an already applied color on a mesh to an emitter and then browse an IES file: the file appears loaded but no light is showed. :)
I can't reproduce this no matter how I setup the IES file. :?:
Science may limit knowledge but should never limit imagination - Bertrand Russell
User avatar
massimo
Licensed User v1.5
Licensed User v1.5
Posts: 1392
Joined: Wed May 13, 2009 7:24 pm
Location: Italy

I can't reproduce this no matter how I setup the IES file. :?:
Nevermind, sorry. Simply forgot to enable the light ... :roll: :oops:
User avatar
giannis
Thea Developer
Thea Developer
Posts: 7986
Joined: Sun Jul 06, 2008 8:25 pm
Location: Athens, Greece

Note: updated to revision 453 with fix for opening IES File in point lights and auto detection of server in network rendering.
There is also an improvement for Viewport fixing problem with distant objects becoming invisible by automatically setting up depth range.
Science may limit knowledge but should never limit imagination - Bertrand Russell
User avatar
Gaieus
Licensed User v1.5
Licensed User v1.5
Posts: 218
Joined: Mon May 11, 2009 3:24 pm
Location: Pécs, Hungary
Contact:

Thanks Giannis for this series of revisions. Indeed a whole lot of things seem to have been fixed now.

(I wrote up a little mention of these revisions in The Daily CatchUp finally.)
Intel Core2 Duo E8400 @ 3.0 GHz | 4 (3.4) Gb RAM | nVidia GeForce 9600 GT (1 Gb)
Windows XP Home 32 bit | Latest SketchUp - or even later :roll: | Latest (public) Thea
User avatar
giannis
Thea Developer
Thea Developer
Posts: 7986
Joined: Sun Jul 06, 2008 8:25 pm
Location: Athens, Greece

This is faster than updating thea website. 8-)

But anyway, I like to give some time before updating the website with latest revision,
so we are sure that everything goes towards the right direction.
Science may limit knowledge but should never limit imagination - Bertrand Russell
User avatar
massimo
Licensed User v1.5
Licensed User v1.5
Posts: 1392
Joined: Wed May 13, 2009 7:24 pm
Location: Italy

Thanks for the fix Giannis. :)
User avatar
Panga
Licensed User v1.5
Licensed User v1.5
Posts: 542
Joined: Mon Jul 27, 2009 3:32 pm
Location: Lyon - France
Contact:

Thanks again Giannis for this revision. ;)
Locked

Return to “Versions & Resources (Studio)”